groongaとlibedit

Pocket

groongaはとてもいいソフトなのだけど、基本バックエンドに徹しているので、ファイルベースの検索に使えるようなフロントエンドを作れるといいなあ、と思いつつちょこちょこ試しています。

ありがたいことに、初めからDebian packageがapt-lieとともに用意されているのですが、groongaコマンドは行編集ができません。調べてみると、libeditに対応しているとのことなので、自前でビルドしてリンクさせてみようとしました。しかし、まだdebになっていないlibedit3を要求するので困ってしまいました。

@ libedit2だと1バイトの文字しか扱えないので日本語とかを入力できなくなります。。。

ということなので、バージョン3は必須のようです。new upstreamを出してほしいというリクエストはすでにあるので、これ以上は待つかNMUするかしないとどうにもならないところです。出したところでwheezyには間に合わないのも困りどころ。

By knok

I am a Debian Developer and a board member of Free Software Initiative (FSIJ).